Cel slajdu: Slajd omawia zagadnienie „Algorytmy kluczy: RSA, ECDSA, Ed25519” w kontekście: RSA, ECDSA, Ed25519 w SSH.
RSA, ECDSA, Ed25519 w SSH
- RSA (Rivest-Shamir-Adleman):
- Najstarszy algorytm asymetryczny, oparty na trudności faktoryzacji dużych liczb złożonych;
- Współcześnie klucze 2048-bitowe uznaje się za graniczne; zalecana długość to 3072 lub 4096 bitów;
- OpenSSH od wersji 8.8 (2021) domyślnie wyłącza przestarzały algorytm podpisu
ssh-rsa bazujący na podatnej funkcji skrótu SHA-1 (zastąpiony przez standard RFC 8332: rsa-sha2-256 i rsa-sha2-512).
- ECDSA (Elliptic Curve Digital Signature Algorithm – RFC 5656):
- Oparty na krzywych eliptycznych NIST (krzywe P-256, P-384, P-521);
- Bardzo zwięzłe klucze i szybka weryfikacja; krytykowany za katastrofalną podatność na defekty generatora liczb losowych (powtórzenie wartości k-nonce prowadzi do natychmiastowego ujawnienia klucza prywatnego).
- Ed25519 (Edwards-curve Digital Signature Algorithm – RFC 8709):
- Oparty na krzywej Twisted Edwards (Curve25519) autorstwa Daniela J. Bernsteina;
- Zapewnia stały czas wykonania operacji (odporność na ataki czasowe side-channel) oraz deterministyczny podpis;
- Rekomendacja branżowa: klucz pierwszego wyboru we wszystkich nowoczesnych wdrożeniach (
ssh-keygen -t ed25519).
Algorytmy kluczy: RSA, ECDSA, Ed25519: Slajd przedstawia zagadnienie RSA, ECDSA, Ed25519 w SSH w ramach tematu Algorytmy kluczy: RSA, ECDSA, Ed25519 na przykładach konfiguracji i diagnostyki w systemie Linux. Architekturę protokołu, wymianę kluczy i warstwę połączenia opisano w RFC 4251 i RFC 4253, a referencyjną implementację stanowi OpenSSH.